Export and Import of a job is creating a new dataset instead of modifying the existing one


I exported a job to file on one computer and then imported it into a different computer (same registered user on the source and target machine). The dataset ID was on the file and it matched the browser. I ran the job and, rather than updating the dataset with the ID in the json, it created a brand new dataset. This was not expected behavior. Is there a setting that I need to do in order to have it work on the dataset on the export file?




Best Answer

  • guitarhero23
    Answer ✓

    I realized I hadn't done it since Workbench 4 so had to go look. On the overview tab click the down arrow on the right of "Domo Details", it'll expand and show a browse button next to "DataSet Name" allowing you to choose a Domo dataset.



    **Make sure to like any users posts that helped you and accept the ones who solved your issue.**


  • That doesn't sound like it should be expected behavior as exporting/importing I'd expect to be the same.


    Try importing it again and this time go to the settings where you can select a Domo dataset and try seeing if the one you expect is listed, even if it is try clearing it out and researching and choosing the desired dataset and see if that does anything different.

    **Make sure to like any users posts that helped you and accept the ones who solved your issue.**
  • Thanks for the reply. This is a Workbench 5 SQL job and I'm unable to find any settings in which I can select a Domo dataset. Can you please advise? Thanks!

  • Very nice! Thank you!


    I did as you suggested, but it doesn't quite seem to work yet. The original SQL did a full table dump, so to ensure that this truly was working, I modified the SQL to replace the dataset with only one row. As you'll see below, the SQL does pull the 1 row, but it also says the dataset hasn't changed and therefore nothing happens.


    [08.23.19 10:20:56 AM] Query String: select * from ps_bus_unit_tbl_fs
    where business_unit = '005'
    [08.23.19 10:20:56 AM] Requesting Domo DataSet Schema.
    [08.23.19 10:20:56 AM] Requesting Domo DataSet.
    [08.23.19 10:20:56 AM] Data has not changed since the last execution.
    [08.23.19 10:20:56 AM] Sending data unchanged status for DataSet.
    [08.23.19 10:20:57 AM] Retrieving execution 3 on Stream 5383
    [08.23.19 10:20:57 AM] Committing Stream 5383 Execution 3
    [08.23.19 10:20:57 AM] Saving Workbench DataSet Job changes to Domo.
    [08.23.19 10:20:57 AM] Updating Agent Job '874' configuration on the Domo server.
    [08.23.19 10:20:57 AM] Reporting DataSet Job execution completion to Domo.
    [08.23.19 10:20:57 AM] Starting notifications workflow
    [08.23.19 10:20:57 AM] Reporting Agent '54' execution status.
    [08.23.19 10:20:58 AM] Recording local stat data
    [08.23.19 10:20:58 AM] Finished dataset upload. 1 rows processed. Total execution time: 0:00:02.2797386.
    [08.23.19 10:20:58 AM] Reloading DataSet Job from the server to reflect changes.


    To address that I went into the Configure tab and that did the trick. Really appreciate your help on this! 


This discussion has been closed.