Error: No agent found matching computer name, or user does not have access to agent

DOMO workbench 5.0.7228.31236 has been installed on my Laptop and when I add account and authorize my machine, the browser confirms the authorization. However while saving the authorization, I get the following error.

No agent found matching computer name, or user does not have access to agent


The following troubleshooting steps were tried.

Tried authorizing inside and off VPN. - No go

Tried uninstalling DOMO Workbench 4.5. Tried to authorize with a token generated by DOMO Admin, still the same error even in DOMO WB 4.5

Installed  & updated dotnet framework latest version.- No go

Windows update to current date. - No go

Added my profile to Admin group in addition to DOMO Users group.- No go

Uninstalled WB4.5 and installed WB5 from my profile - No go


Below is the log taken from Workbench log

[INFO] [9488:4] 2019-11-19 00:01:12,247 - Starting Workbench.Service v5.0.7228.31236
[INFO] [512:1] 2019-11-19 00:05:46,362 - Starting Domo Workbench v5.0.7228.31236
[INFO] [9488:8] 2019-11-19 00:06:28,933 - Configuration changes detected, reinitializing service.
[WARN] [512:1] 2019-11-19 00:10:14,401 - Failed to create agent
[ERROR] [512:1] 2019-11-19 00:10:15,198 - An error occurred during the save
System.Exception: No agents found matching computer name, or user does not have access to agent.
at WorkbenchSDK.Account.DomoAccount.<Save>d__6.MoveNext() in C:\jenkins\workspace\Workbench\WorkbenchBuild\WorkbenchSDK\Account\DomoAccount.cs:line 274
--- End of stack trace from previous location where exception was thrown ---

Please help!


Best Answer

  • user18108
    user18108 ⚪️
    Answer ✓

    I had reached out to DOMO Premium support and below is the solution provided.

    1. They identified that the laptop used by me was also used by a different DOMO workbench user earlier.

    2. They suggested changing my lapotp name. However that was not authorized by my org.

    3. They instructed my Orgs DOMO Admin, to temporarily elevate me as a DOMO Admin and then when Authoizing my computer this time it went through.

    4. I was instructed to Delete my Account in workbench. VERY IMPORTANT - Delete the Jobs as well.

    5. My DOMO Admin again de-elevated me to DOMO editor and again I authorized my laptop and this time it went through.

    Thank you everyone for trying to help me out. 


  • user18108,


    This sounds like an issue that would need to be investigated by Domo Support. They have workbench experts that could help get to the bottom of it with you.


    From your Domo instance, click the question mark in the top right and then click the Support link in the top right of the help center. You can create a ticket there. To help triage it more quickly, choose "Connect" as the Support Category, and "Workbench" and the Support Sub-Category.

  • Thank you for the reply zcameron. I am using workbench 5 and the help icon is on the lower left of the screen. Clicking on that takes me to a screen "Get help setting up and managing workbench". The links on the page are to Domo university, Dojo, Knowledge base and developer portal.

    Please let me know if I am missing anything 

  • @user18108  This is likely a permissions issue on the machine where workbench is running. Try running it as an admin to confirm.


    If you are able to run it successfully as an admin, you probably need to be added the the Domo Workbench users group on the machine. There's some instructions on how to set up this group here:

    Essentially, you will likely need an admin on the machine to add you to the group or you will need to run Workbench as an admin.

    **Say "Thanks" by clicking the "heart" in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
  • The help icon I was referring to in the Domo instance, not in Workbench. Sorry for the confusion.

  • I have already been added to the DOMO Access group and I have also been provided Admin access to my computer.

  • Thanks again Zcamaron. My bad! I did not know the difference between DOMO instance and workbench. Have created a case now. Thank you for the directions.

  • @user18108 


    Thanks for sharing this important solution! We will look to create a Domo article on this unusual situation.




    CC @bengreen 

This discussion has been closed.