Filter on a dashboard with multiple data sets not working for all cards

I have a dashboard that has cards from 3 different data sources. When I set up the filters for the page, I think they may have all come from just 1 of the 3 data sources because when i use the filters, only cards from the 1 data set get appropriately filtered. (I did check, and all of the names are the exact same in all 3 data sources)


I did check the card interaction settings and all cards are set to 'Enable interaction filters' to 'Apply to all cards on dashboard' so I really have no idea what else to do.


Anyone know how to get filters to work across multiple data sources??

Best Answer

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🥷
    Answer ✓

    I think I had the same problem as you a while ago. When you click on Add Filter, click on the arrow to the right of the column you are wanting to filter on. Then click on Select All. Here are some screenshots to help you.


    This should make your filter apply to all the datasets on the card.

    Hope this helps.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.


  • Replying back to my own post Cat Embarassed -->

    When I added the filters, I must have either only had one dataset in use or did not see the carrot/dropdown to apply to multiple datasets. When you Add a filter, if the same name of a dimmension is used on multiple datasets sourced on that dashboard, it will give you the option to select as many of those datasets as applicable. 

    To note, this did highlight for me that one of my filters was called 'contract' in some data sources but 'contract_name' in others. I made a new calculation on the data sources that had 'contract name' so there was another column called contract (the formula was just referencing the `contract_name` field) & applied to the data source. This allowed me to handle the different names from different sources.

    Sorry I didn't figure this out before posting but hopefully someone else will find this helpful someday!

  • Thanks for posting this! I obviously did not see your reply when I responded. Ugh - new to using Dojo!

This discussion has been closed.