character in saved beastmode some how replaced with exclamation point - !

Good morning


Has anyone ever experienced a character in a beastmode syntax being replaced by an exclamation point?


I created a beastmode probably about a year ago and validated it against the data, and at the time, it worked properly.  We've since updated to a different dataset and copied all the beastmodes from the old data set over to the new data set, and have made sure to account for any column name changes with in the beast mode.


I discovered that this beastmode is no longer working correctly, and when I examined the syntax, I see there are two exclamation points in it.  I don't think I would have originally put those in there because I can't remember ever using exclamation points in a beastmode, or know if they even serve a purpose.  But the formula says it is valid when I test it, so that is odd, too.


If I had to guess, I think the original characters were maybe less then or greater than characters, but I tried insterting those and testing the beastmode and it still did not work correctly, so I'm not 100% sure


Has anyone ever heard of a specific character or beastmode function or column being replaced by an exclamation point in a beastmode?



Best Answer

  • jaeW_at_Onyx
    Answer ✓

    wow no, I've never heard of that.


    The beast mode manager (is still in beta, ask your CSM for details) will help you identify problematic beast modes.


    In the immediate term, you can deploy the beast mode governance dataset to your instance.    It will then allow you to search the 'code' text of all your beast modes, as well as identify beast modes that do not validate.

    Jae Wilson
    Check out my 🎥 Domo Training YouTube Channel 👨‍💻

    **Say "Thanks" by clicking the ❤️ in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"