Issue with MongoDB atlas Connector, it keeps throwing error "Time out"

Good day, 

 

We used the MongoDB atlas Connector to connect with the mongodb database, I already whitelist my public IP address(to get my IP public address I used ipchicken.com), but it keeps throwing error "Failed to authenticate. Verify the credentials and try again. Time out." 

 

Here are my configurations in mongoDB atlas:

 

Driver: JAVA 4.1 and later

 

CLUSTER: TIERM0 Sandbox (General)

REGION: Azure / Virginia (eastus2)

TYPE: Replica Set - 3 nodes

LINKED STITCH APP: None Linked

 

Can somebody help with this, Im stuck with this error.

 

 

Comments

  • jaeW_at_Onyx
    jaeW_at_Onyx Budapest / Portland, OR 🟤

    Given that your error message suggests a credentials error, I would try using any other IDE to connect to your mongDB, maybe VS Code or a local SQL management tool that you know has worked historically.

     

    Once you've confirmed that credentials are not part of the problem, maybe try connecting with any sort of VPN disabled. 

    Jae Wilson
    Check out my 🎥 Domo Training YouTube Channel 👨‍💻

    **Say "Thanks" by clicking the ❤️ in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
  • Yhap, the credentials are all working I used MongoDB Compass, also I don't use any Vpn. 

  • jaeW_at_Onyx
    jaeW_at_Onyx Budapest / Portland, OR 🟤

    Oof... it may then make sense to direct your question to [email protected]

     

    there is an old dojo thread https://dojo.domo.com/t5/Data-Sources-and-Connectors/MongoDB-non-SSL-connection/td-p/8239 that mentions having to use SSL to create your connection.

     

    Also they suggest pushing the data via Workbench.  

    Jae Wilson
    Check out my 🎥 Domo Training YouTube Channel 👨‍💻

    **Say "Thanks" by clicking the ❤️ in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"