Recursive Data Flow Renaming Output DataSet with "1" Rather than Input

After running the ETL and Adding the Output as an Input, Existing Output is renamed rather than the Input.  Why is this occurring?  See attached.

Best Answers

  • GrantSmith
    GrantSmith 🥷
    Answer ✓



    You can run it so the dataset will update the name (It's still the same dataset). After it's been run once you can then go back in and add the renamed dataset as your input and then change your output back to the correctly named version.

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**
  • JennieElf
    JennieElf ⚪️
    Answer ✓

    I may be oversimplifying but I had the same issue when I was building a recursive. Finally realized that I had to break the link between the Input DataSet and the Output DataSet BEFORE I dragged over the other Input DataSet which I would load with the Recursive Data Flow.  It's worked perfectly since I started doing that.