How do I remove duplicate rows in a card drilldown?

I have a card that is created by counting IDs and when I drill down into the card, it shows all the rows for that ID. I just want to show unique rows for a user ID. Attached is the screenshot for my data.

I want my drill down to look like this.

Basically, I want to remove the duplicates in the drill down. Is there any way to do it in the card using beast modes?


Best Answer

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🥷
    Answer ✓

    Add another column that aggregates a field by using the count or sum, for example, and it will remove the duplicates. You can do this by dragging another field over and then click the pencil icon next to it and choose one of the aggregation options. Make sure you don't have anything that is in the sorting properties

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.


  • Thank you @MarkSnodgrass this worked.

  • SaloniShah
    SaloniShah Michigan ⚪️

    Can someone please elaborate on this? I still can't find a way to remove duplicate rows.

    Thanks in advance.

  • jaeW_at_Onyx
    jaeW_at_Onyx Budapest / Portland, OR 🔴

    @SaloniShah post a picture of what you're currently doing / strugglign with.

    Jae Wilson
    Check out my 🎥 Domo Training YouTube Channel 👨‍💻

    **Say "Thanks" by clicking the ❤️ in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"