Setting Default Datasets for Page-Level Filters

Hello Domo Community, 

I have a dashboard with page-level filters. 

The dashboard and the filter views have been shared with my company. I have chosen the Dataset I want the page-level filters to run off of, however, when other users log-in it switches to a different dataset that does not have all of the filters that I want my team to see.

Is there a way to set a default dataset for page-level filters?

Thank you!

Answers

  • jaeW_at_Onyx
    jaeW_at_Onyx Budapest / Portland, OR 🔴

    @cassandra_cook1 what do you mean by "switches to a dataset?"


    one generally does not simply change the datasets that powers cards.

    in any case if a filter is set up without specifying the dataset then it will apply that filter to all cards on the page that have datasets that include the column name on which the filter was applied.

    Jae Wilson
    Check out my 🎥 Domo Training YouTube Channel 👨‍💻

    **Say "Thanks" by clicking the ❤️ in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
  • Ashleigh
    Ashleigh Florida 🟣

    @cassandra_cook1 it may also be useful to just make some filter cards that way you always know the users are filtering on the correct dataset.

  • I have attached an image to show what I mean by switching the dataset. I want all of the page-level filters to be filtered by the "Dataset for filtering" line, however, it always switches back to the other data set once users log out. We are trying to avoid filter cards since they take up space on the dashboard and we have a large number of filter options. Thanks in advance for your help!

    @Ashleigh @jaeW_at_Onyx @amehdad


  • jaeW_at_Onyx
    jaeW_at_Onyx Budapest / Portland, OR 🔴

    oof... this looks like heartache waiting to happen.

    i usually recommend that you have one dataset per dashboard. so basically take all your datasets and UNION / APPEND them into one dataset called DASH_..


    conform your column names as appropriate, and then you know you're applying filters to the right thing.

    the way you're currently setup you're relying on users to NOT make mistakes. which ... of course is not gonna happen and is part of why you're navigating the struggles you're working on now.

    https://www.youtube.com/watch?v=rS2e2_fv5yk&t=1445s

    Jae Wilson
    Check out my 🎥 Domo Training YouTube Channel 👨‍💻

    **Say "Thanks" by clicking the ❤️ in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
  • Another option is manual (and definitely not worth doing if you have PII data or similarly sensitive data) but you can have a set of filters applicable for each group via 'Save Filters' and 'Share with everyone' that you manually point (i.e. Click each filter and set whichever dataset in 'Show filter values only by the selected DataSet' towards the relevant one for your user groups). For example, the office manager(s) can view your dashboard and apply a page filter (say it's called 'Office Manager') that will be powered by the 'Office' dataset only. Drawbacks are that it's time consuming, filters can be accessed by other users, and not best practice. If you are ok with that htough, then this is where the user behaviour element comes in and you'll need to educate your users to click 'Filter Views' and only apply the saved filter that is relevant for them.

  • I heard back from the Domo support team that " the default dataset is based on the number of cards on the dashboard using the dataset. Unfortunately, there are no additional options at this time for setting a default dataset on a page filter."


    We ended up just adding a bunch of cards powered by the dataset at the bottom of the dashboard but made them white so that the dataset we wanted was the majority and thus automatically chosen for the filters.