Beast Mode Calculation in Summary Number

My beast mode formula goes something like this:- SUM (x) / SUM (y)

I am not able to use the above beast mode for my summary number. I am looking to get the average percentages, but the aggregation field is greyed out and I get the message "using aggregation in beast mode formula". Any help will be appreciated. Thank you

Tagged:

Comments

  • GrantSmith
    GrantSmith Indiana 🥷

    Hi @Saketh

    You're attempting to aggregate an aggregate which isn't possible within the beast mode and summary number. If you want the average of the percentage you'd need to pre-aggregate your data with a dataflow to then be able to take the average of the percentage.



    **Was this post helpful? Click Agree or Like below**

    **Did this solve your problem? Accept it as a solution!**
  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🥷

    @Saketh since you are already aggregating it, you just need to ignore the aggregation field and click on Show Formatting Options and then choose percentage for the Display As format. You will then see your summary number as a percentage.


    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • @MarkSnodgrass - Thank you for the above fix.

    Quick follow-up question - would the averages displayed be a weighted average or is it a simple average??

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🥷

    @Saketh this would just be a simple average since you aren't putting a weight on anything.

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.