Data Table no thousands separator

I am importing case data from Salesforce. The case number always comes in with thousands separator. Is there any place where I can default to just give the number without the separators? Best would be directly upon import. Or then later in the ETL.


Thanks for any ideas! Caroline

Comments

  • GrantSmith
    GrantSmith Indiana 🥷

    It's showing the thousands separator because it's a number but it likely doesn't actually have the separator in the value. It's a display enhancement to make numbers easier to read. To do a quick test you can view the data in a table card and they shouldn't show up there.



    **Was this post helpful? Click Agree or Like below**

    **Did this solve your problem? Accept it as a solution!**
  • 😁 And two minutes later I found the answer myself.....

    In the ETL, at the Input Data Set going to Settings for Integer and change to en-US....Does the trick...


  • Opening a new topic. The thousands separator only dissapears in the preview. Not in the actual data...unfortunately....

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🥷

    When you are in Analyzer and editing the card, click the pencil icon when you hover over the field and choose Format and then choose Display as Number and uncheck the Use Thousands Separator option. This will display your number without any thousand separators.



    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • HI Mark,

    this did not work for me, when I drill down in data, the thousands separator shows again. In another post, I got the recommendation to change to Text format. That did the trick.

    Thanks!

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🥷

    Another option would be to create a drill path to a table card rather than to the raw data and do the format option as suggested. This would allow you to keep it as a number in case you need to do any calculations.

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • I have not yet used drill paths, I just started with Domo a few weeks ago. But I definitely put it on my bucket list 😀

    The issue with the thousands separator is more of an inconvenience now.