How to cancel/stop/suspend ALL workbench jobs temporarily

I've submitted to Domo Support this morning, but thought I'd check with the Dojo to see if anyone has a solution.

I have about 60 workbench jobs that appear to be stuck this morning and are showing as "running". They seem to be stacked up in queue and are not getting anywhere. This traffic jam is growing as scheduled jobs are attempting to run and are queued behind the others. I tried "stopping" and "starting" the Domo Workbench service... and even clicking the "X" or "Schedule Edit" on individual jobs and it doesn't do anything.

How can I cancel/stop/suspend ALL workbench jobs temporarily?

I am using Workbench 5

Answers

  • GrantSmith
    GrantSmith Indiana 🥷

    Hi @swagner ,

    The fastest option is to indeed stop the Domo Workbench service. This will prevent new jobs from being added to the queue to be run. I've run into issues like this in the past where jobs will be stuck in a "running" state on workbench but the job will have completed in Domo itself. When telling a job to cancel it won't do anything. The only way I've found to resolve the issue is to reboot my workbench server. I too have an open support ticket for the specific issue.

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**