Checkbox Selector not showing all values?

Good morning,

While trying to create a Checkbox Selector to use as a filter, I've run into an issue where the card is only showing some values instead of them all. It's not even a massive data set; it's 15 values. However, when creating the card I see the dreaded "Warning: Not all data is shown" message (14 of the 15 are selectable). Any thoughts on what might be happening here? Limit Rows is set to default (All Rows). This is really weird. Thanks.

Comments

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🥷

    If you don't have anything in the optional group by field, I would put the same field that you have in the items field into the optional group by and choose count as the aggregation type. I would also check the date range filter if your dataset has a date field and see which field it is using for the date range. If your dataset has multiple date fields, Domo may be choosing a date field that is incomplete, causing not all fields to display.

    If neither of those fix the problem, selecting Reset Chart Properties can help as well. Also, I'm assuming there is nothing in the filter properties that would exclude one of your items.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • Joe_M
    Joe_M ⚪️

    That did it! I have no idea why though. Appreciate the insight, as always.

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🥷

    That's great to hear @Joe_M . If you have the option to accept answer on my response, that will help others in the community.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • Joe_M
    Joe_M ⚪️

    Of course.

  • Joe_M
    Joe_M ⚪️

    Hmmm...I either did or it won't let me anymore. Apologies!

  • efreimuth
    efreimuth ⚪️

    @MarkSnodgrass this did it for me too, thanks!!! Once I put the Optional Group By and changed aggregation to Count it solved my problem. I only had 12 filter items (most recent 12 months, but it was text format instead of date format).