Beast Mode - Multiple functions

BTPG
BTPG ⚪️

I've created a beast mode which is correct to add 2 working days to a date.

However I want then be able to group this new date into calendar weeks. I used WeekofYear Beast Mode which came out as valid but when I graph this then drill into the week is the first date for the week is Thursday not Monday.

I assume that based on how I did this I can't have 1 beast mode and then use that beast mode for the DataSet Field and I need to make 1 beast mode.

Any ideas how to do this?

What I have with the beast mode used as a data set inside another beast moade

WEEKOFYEAR(DATE(DATE_ADD(`estimated arrival at pod date`, INTERVAL (FLOOR(4/5) * 7 + CASE WHEN MOD(4,5) + DAYOFWEEK(`estimated arrival at pod date`) >= 7 THEN 2 - FLOOR(DAYOFWEEK(`estimated arrival at pod date`)/7) ELSE 0 END + MOD(4,5)) DAY)))

Best Answer

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🥷
    Answer ✓

    If I am understanding you correctly, I think you have two options:

    1. In your main card, use the beast mode that returns your desired date. In Analyzer, set the Date Range filter to use this date field and then set it to graph by week. This will display the week of year for you in the card. When you drill, it will still be using this date field and should display the correct day for you.
    2. If you don't like how it displays the week in the first option, use your weekofyear beast mode and put that in the x-axis. When you drill, you need to configure the card in the drill path to use a different beast mode, one that returns an actual date, and put that in the x-axis. You can't use your beast mode that returns the weekofyear as a date field because it just returns an integer, so you need to make sure that you are using a beast mode that returns the desired date and use that field in your card.

    Hope this helps.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.

Answers

  • BTPG
    BTPG ⚪️

    Thanks Mark, I followed point 1. I didn't need the second beast mode, I just needed the graph setting in the date filter.