Workbench replacement variables not saving

joel_weber
joel_weber ⚪️
edited January 4 in Workbench

I've been working with Domo workbench for a few months and have created a handful of jobs that use the 'Append' method as well as a replacement variable to update. I've had this issue every time I've created one of these jobs but I've always managed to get it working after enough messing around with the order of operations, deleting the dataset several times and starting over, etc.

The issue I'm having is that I can't seem to get a replacement variable to stick. I create the variable, save and run the dataset, and when I go back, the variable doesn't exist and doesn't have a value. I've tried every iteration I can think of and no luck (or at least no consistent luck). The current method I'm using (which worked for the last job I created, but not this time) is as follows:

  1. Create the dataset
  2. Set the update method to 'Replace'
  3. Create the replacement variable (without the '!{lastvalue:x}!' in the WHERE clause of the query)
  4. Run the job
  5. Change the update method to 'Append'
  6. Check the replacement variable to see if it has a value

It's at this point I hit a wall because the replacement variable is gone. If I ignore and try to run the job after putting the '!{lastvalue:x}!' into the WHERE clause, it obviously fails.

I could really use some help on this issue as it makes using workbench a serious headache.