Independent filtering within a dashboard, using the same column

bradw
bradw ⚪️

Hi,

I have a dashboard that tracks our current sales performance for the day with various comparisons, which works great. I've had a request to produce a version of this that would allow end users to select two dates, and then comparisons would run between these dates.

I'd need to filter different cards, with different values for the same filter column. In the above simplified example I'd want each card to be filtered by a separate date selected by the user. My challenge is I can't see how I can have multiple filters for the same column and map these to the specific cards.

Could somebody help me on how I can best achieve this in Domo?

Thanks,

Brad

Best Answers

  • GrantSmith
    GrantSmith Indiana 🥷
    Answer ✓

    Hi @bradw

    Due to how filters function within Domo you can't have a single filter column and multiple values applying to different cards. You could copy the date value into a different column and then have the other cards use the new column instead of the first column so they're separate values to filter on. Because you're using dates you'll want to also disable the global date filter on the page otherwise both will be filtered based on the same date.

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**
  • Godiepi
    Godiepi 🟣
    edited June 30 Answer ✓

    @bradw you have to adjust the interaction on each selector independently to enable interaction filters to ONLY apply to selected cards. clicking on CHANGE will open the list of all the cards in your dashboard, from there you can select the specific card.

    You want selector1 to only interact with Card1 .... and Selector2 to only interact with Card2


    It is very tricky as you have to turn off the Date filtering Global settings

    Try also creating 2 beastmodes for the same date DATE() but name them differently. also in the cards to filter make sure the date column they use is the beastmode for each.


    you should be able to get this:


    Domo Arigato!

    **Say 'Thanks' by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as 'Accepted Solution'
  • Godiepi
    Godiepi 🟣
    Answer ✓

    @bradw I understand the process to make it work is a little difficult. let me layout for you by step

    You are working with [Order Created Date] for your filter and [Sales Amount] for you single value card

    1. Create 2 Beastmodes around [Order Created Date]as follows :
      1. Beastmode 1 = [Order Created Date1] formula = DATE(`Order Created Date`)
      2. Beastmode 2 = [Order Created Date2] formula = Date(`Order Created Date`)
    2. Create 2 Date Selector cards as follows
      1. Card 1
        1. Name = Date Selector1
        2. Card Type = Filter Date Selector using beastmode field [Order Created Date1]
        3. Make sure in analyzer that the date range field in use is [Order Created Date1]
      2. Card 2
        1. Name = Date Selector2
        2. Card Type = Filter Date Selector using beastmode field [Order Created Date2]
        3. Make sure in analyzer that the date range field in use is [Order Created Date2]
    3. Since you already have the single value cards showing the sum of amount created as Date 1 Sales and Date 2 Sales, the only step here is :
      1. Open Date 1 Sales in analyzer
        1. Go to the right upper corner and adjust the date range field to use [Order Created Date1]and saved.
      2. Open Date 2 Sales in analyzer
        1. Go to the right upper corner and adjust the date range field to use [Order Created Date2]and saved.
    4. Place the 4 cards in the dashboard
    5. On the dashboard page go to the wrench icon (Dashboard settings) and choose the last option at the bottom Filter Options to uncheck the option of Allow Global Date Filters
    6. Go to the dashboard settings again and adjust the interaction of each Date Selector to only affect one of the cards
      1. Date Selector1 apply to only Date 1 Sales
      2. Date Selector2 apply to only Date 2 Sales

    Let me know if you still can't get it to work because it works for me just fine. if you still have issues I dont mind jumping on a quick call to walk you through.

    Domo Arigato!

    **Say 'Thanks' by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as 'Accepted Solution'

Answers

  • bradw
    bradw ⚪️

    Thanks @GrantSmith I suspected it wouldn't be possible, but just wanted to be sure I wasn't missing anything. Thank you for your help.

  • @bradw You can created 2 Filter cards, locate them on top of each of the cards in your dashboard, then adjust the interaction settings so that [Date selector 1] only filters the card [Date 1 sales] and [Date selector 2] only filters the card [Date 2 sales] within your dashboard... that's the only way you can do that

    Domo Arigato!

    **Say 'Thanks' by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as 'Accepted Solution'
  • bradw
    bradw ⚪️

    I did try that @Godiepi but I found that the selectors overwrite each other, so if I set a date in selector 1 it applies to sales 1, but then when I set a date in selector 2 it clears the date selected by selector 1. So creating a duplicated date seems the only way to do what I'm after, unless I'm missing something in your solution.


    Thanks,

    Brad

  • bradw
    bradw ⚪️

    Thanks @Godiepi I set up the card interactions as you described and disabled the global date filters. The separate date selectors filter the correct card, but then when the other date filter is selected the first one is cleared. I am guessing as they use the same base column. Duplication of the date column using beast modes or etl seems to be the only way to achieve what I'd like. Thanks for your help.

  • bradw
    bradw ⚪️
    edited July 5

    Thanks for the step by step guide @Godiepi, I think what I was missing was linking the beast mode dates to the specific value cards in the date settings. It's working now as you describe. Thanks for the solution here and walking me through it.