Postgres SSH Connector - Data Types not importing as expected

I am currently using the Postgres SSH Connector to import datasets from our warehouse into Domo. When I try to import a boolean column it is imported into Domo as a string, and often the primary key field which is an integer in the warehouse is imported as a float. This kind of defeats part of the point of using a connector to my warehouse, so that I can do the heavy lifting of transformations, pre-clean, and aggregate data in SQL before bringing it into Domo for BI.

Is the only option here to explicitly cast data types in the SQL Query pulling it into Domo? Or am I overlooking something that helps solve this problem?

Tagged:

Best Answer

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🥷
    Answer ✓

    Often when a field doesn't come in as the type I expected, I use Magic ETL to cast it to the appropriate type and then use the output dataset for my cards. There are a couple ways to do this in Magic ETL, on the input dataset, you can click on Configuration and then on Data Handling and then change the field to the type you want. You can also the Alter Columns tile or the Formula tile and then use the CAST function in the formula editor.

    Hope this helps.

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.