Capture error in a Card

andres
andres ⚪️

We're currently using a Range Selector card to allow users to filter our data based on a MIN and MAX date. The problem is that we sometimes have no data when users initially access our platform and they see the error "Error: The maximum value is less than the minimum value" and that leads this to thing that there's an actual problem with our side (see the image below)

Apparently, the rest of the filter types throw no error when there's no data and I've not been able to find any settings in the card building section that allow me to rephrase the error or handle it better. Is there any way I could handle this?


Tagged:

Answers

  • @andres You can change what the users see if there is no data under Chart Properties - General - No Data Message. I'm not familiar with this particular error, though, so you will have to test this to see if it works

  • andres
    andres ⚪️

    Hi @MichelleH,

    Thanks for the answer, but I already tried that with no luck. The default "No Data available" message appears on the rest of the cards and also on this one if I pick a different filter type.

  • @andres Can you please share some screenshots of your date filters?

  • andres
    andres ⚪️

    @MichelleH

    Sure! For some reason I thought that I'd already included them at the top.

    Working Example

    The Filter Type that we're using

  • @andres Are you using the same date field for your Minimum Value and Maximum Value?

    **Was this post helpful? Click Agree or Like below**

    **Did this solve your problem? Accept it as a solution!**

  • andres
    andres ⚪️

    @RobSomers yes, it's the same date field

  • @andres Is the date field a beast mode?

  • andres
    andres ⚪️

    @MichelleH No, it's a normal date field. Below you can find a couple of examples


  • @andres

    Can you create a table card with 3 columns ? User, MIN(Date), Max(Date) then filter to the user or users that get the error to actually see what the MIN and MAX columns display? is because nulls , is it a generic date associated that is messing up ? etc ..

    Domo Arigato!

    **Say 'Thanks' by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as 'Accepted Solution'
  • GrantSmith
    GrantSmith Indiana 🥷

    @andres

    I'd recommend logging a bug with Domo Support. That message shouldn't appear if there's no data. The No Data message should appear instead.

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**