DATETIME field with NULL value

I am running into an issue where when I load up some data via workbench there is a table that has a DATETIME field where the default value is NULL. When workbench is querying that, it absolutely does not like that there is a NULL value in that field. It takes about 20+ hours to run the entire process. I removed the column to test it out and the entire process finished executing in around 6 minutes. Is there anyone else handling something similar to this? If so, how are you able to allow workbench to do this without a hiccup.


Thanks

Tagged:

Answers

  • GrantSmith
    GrantSmith Indiana 🥷

    Is it the querying that's taking a long time or the data upload to Domo that's taking a long time?

    Are you joining to another table causing the null values? If so when you removed the null column did you only exclude the field from the query itself, uncheck the columns to upload in the schema or remove the table join as well?

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**
  • Jmoreno
    Jmoreno ⚪️

    It is the querying. The portion before the process monitor says:

    "[07.14.22 2:57:53 PM] Finished reading XXX,XXX data rows." and so on

    There is no join as far as I know, and when I removed the column I simply excluded it from the query itself.

  • Lewis
    Lewis ⚪️

    @Jmoreno, Did you find an answer to this? We're having some issues related to null DATETIME values, wondering if you ever discovered the root cause..

  • @Lewis

    We have identified that the major issue that is causing this is if you have the timezone conversion activated on the workbench job. We removed it, ran a replace of the whole dataset, then re-added it back in and it seemed to have fixed itself.... for now. We have been running into quite a few issues regarding DATETIME fields recently after their daylight savings update.