Snowflake Federated Connector 'No federated agent was found for the provided values...'

Have been using snowflake federated connector for about 3 months no issues then today all of a sudden receiving this error. The error displays when trying to 'create' the dataset meaning I am able to navigate through the scheme browser, select and view the dataset I want to connect but once I get to the final menu and select create I receive this error:

'No federated agent was found for the provided values. Agent ID: CLOUD, Datasource ID: null'

I submitted a DOMO support ticket but it seems wait times have been much longer than usual, hoping that someone in the community has encountered/resolved this issue before.

Answers

  • jaeW_at_Onyx
    jaeW_at_Onyx Budapest / Portland, OR 🔴

    blind guessing here, but looks like the datasource id got blanked out. it's unclear to me if that means the of the dataset in Adrenaline or the config information for your dataset on premise, but if it were me i'd open up the federated agent configuration tool and see if there was something going on.


    can you spin up another connector to the same dataset?

    Jae Wilson
    Check out my 🎥 Domo Training YouTube Channel 👨‍💻

    **Say "Thanks" by clicking the ❤️ in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
  • crico
    crico ⚪️

    @jaeW_at_Onyx This is the only snowflake connector we have. We also never had to set up the federated agent as we are using the cloud connector

  • jaeW_at_Onyx
    jaeW_at_Onyx Budapest / Portland, OR 🔴

    sorry i assumed you were using federated on-premise agent.

    this guy? https://domohelp.domo.com/hc/en-us/articles/360049429094

    I really don't know the answer but I would try setting up a new connection JIC an invisible update deployed a new set of connection config params.

    Jae Wilson
    Check out my 🎥 Domo Training YouTube Channel 👨‍💻

    **Say "Thanks" by clicking the ❤️ in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
  • Thanks for the help! turns out it was something changed on DOMO side that they have now resolved!