Unable to Schedule Jobs

Hi everyone, I can manually run a job which works, however when I schedule a job, it says that it executes however the job does not run and I don't see it in the UI. When I look at the viewer, I see the following error:


'Could not fix consecutive blocks of CRON schedule'


Does anyone know how to resolve?

Comments

  • Adding a comment here to tag along with this issue as I am also getting the same issue as of maybe a week ago this started happening. Before it was running just fine.

  • @mroker can you provide more details as to where this is happening?

    **Say “Thanks" by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
  • We reached out to domo support and they responded with:

       Hi, we have a fix for the scheduling issue in workbench. It can be fixed by clearing the schedule (selecting manual run), saving, then setting a schedule again. There was an update to our CRON library for Daylight Savings Time . Please follow the instructions above to correct the issue. Thanks Domo Support

    I have given that a try but will not know if all good until the next re-run which is in 2 hours for me. Will keep you all posted.

  • Alright I come back with an update on my previous comment.

    Their solution did not work for me ... but I have fixed my issue.

    I had a group schedule with 18 jobs in it that all run in parallel. I figured maybe the load was too much on just one single group schedule. So what I did was I split it into 2 group schedules that run only a minute apart. All 9 jobs on each one still run parallel.

    KEY NOTE: I noticed that when creating the group schedules there is a "Basic Schedule" and an "Advanced Schedule". I was trained to use the advanced one since that how things were being done here when setting jobs that have an interval refresh time like every 1 or 2 hours. Well I noticed the Basic Schedule has what I needed without going into the Advanced one, which is to run it every 2 hours. So I went ahead and set these 2 groups to run every 2 hours with the Basic Scheduler. In the last 50+ runs, all of them have been successful.

    I hope this helps you out