Why have the dates changed?

damen
damen 🟠

So I have put together a multi data source dashboard for our company. Yesterday, before everything ran overnight, all of the years worth of data was showing up. This morning, without changing any filters, the graphs are only showing about 15 years worth of data.

My instinct said that somehow the update caused to data to go missing but I see the earlier dates in the data in analyzer.

Is there a fix for this without having to recreate each card? (I still cant get all the way back to 1977 even when I recreate the card but it does go back further.)

Any insight would be helpful. Again no filters were applied and when I enter into analyzer, the date range still says 1977 to 2022

If this helps, feel free to agree, accept or awesome it!

Tagged:

Best Answer

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🥷
    Answer ✓

    @damen I have run into issues where I have a lot of historical data and if the date range filter is set to graph by year, it does not go all the way back. Support once told me that it has to do with their calendar system behind the scenes.

    I was able to get around it by creating a beast mode that extracts the year from the date field that is on the x-axis and then put that beast mode field on the x-axis. The beast mode is simply YEAR(`datefield`) . See if that works for you.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.

Answers

  • @damen Does your source data still have the correct dates outside of Domo?

  • damen
    damen 🟠

    @MichelleH Yes. Most of the source data comes from databases that aren't rewritten but appended. The earliest dates from all sources in this dataflow are like this and have not been overwritten.

    If this helps, feel free to agree, accept or awesome it!

  • @damen You mentioned that you aren't able to find the older data in analyzer. How are you looking for it in analyzer?

  • damen
    damen 🟠
    edited October 17

    @MichelleH So the 2nd screen shot is showing that the dates are available in analyzer. That view if of the 'data' table while in analyzer. The problem is the card isn't showing all the available data.

    Here is a different view but basically showing the same thing that was mentioned by the previous post/pictures.

    This is the same instance of analyzer.

    If this helps, feel free to agree, accept or awesome it!

  • @damen What is your y-axis field? Is it a beast mode or a column from your dataset? If it's a beast mode, could you post what it is?

    **Was this post helpful? Click Agree or Like below**

    **Did this solve your problem? Accept it as a solution!**

  • damen
    damen 🟠

    @RobSomers Its just a regular column. We aggregated it on average purchase price by year.

    I just went through and removed all aggregates and changed from ave to all the other ones and the same issue is coming up.

    If this helps, feel free to agree, accept or awesome it!

  • damen
    damen 🟠

    @MarkSnodgrass Awesome. Yeah. That worked. Thank you.

    If this helps, feel free to agree, accept or awesome it!