Help - Period over Period w/ Beast Mode Week Field

Rak
Rak ⚪️

I am wanting do a year over year comparison that uses a beast mode date field for the X axis. The idea is to get actual dates of the week instead of using Week 1-2022, Week 2-2022,etc. It looks like the option to do YoY comparison is not valid when I try to do that. See image below. I am also inserting a view of my beast mode logic.

Beast Mode:

Ideally it would look like this with the dates of the week instead of the week number:


Answers

  • Aditya_Jain
    edited November 1

    Hi @Rak

    It seems that your calculated date field is not a 'Date' field yet, it's still a string field and hence won't work with YoY charts. Probably revisit the calculation for 'Date Week' Beast mode, or else put the formula here so that we could help you with it.

    Please ignore this comment


    Regards

    Aditya Jain

    'Happy to Help'
  • @Rak

    Please use the actual Date column as the beast mode that you have written has a concat() around your logic hence it would result in a String. So please form your date and do not put it under concat(). Also if you use Your date column, and try changing the format under general settings, X axis settings, it might work.

    Let me know how it goes.


    Thanks

    'Happy to Help'
  • Rak
    Rak ⚪️

    @Aditya_Jain this does not work. Removing the concat function will not validate.


  • mhouston
    mhouston 🟢
    edited November 1

    @Rak is it an option to change this globally across your domo instance? In the Admin > Company settings, there is a week display option that you can toggle between Week Number and Week dates:

    This would be the easiest way to achieve it (without having to convert your dates using a beast mode).