Host name for ElasticSearch Connector?

Hello, I am trying to set up an account for the premade ElasticSearch Connector. This connector requires three fields: Host, Username, and Password. I have a working username, password, and URL for manually logging into Elastic, however I have not been able to come up with a working permutation of the URL to use in the "Host" field.

If anyone has gotten this connector working, could you share an example of what the Host name should look like?

Tagged:

Answers

  • TDanis
    TDanis

    domo

    💎

    @mlee It would be a custom URL where your ElasticSearch is hosted, with a port number on the end of it. I've seen ones like these used in the past "https://example.us-west-1.aws.cloud.es.io:9243" or "https://12a234b45c678d7899d.us-west-1.aws.found.io:9243"

    If I have answered your question, please click "Yes" on my comment option.

  • mlee
    mlee ⚪️

    Thank you for your response, TDanis! Unfortunately, that format is not working for me in the connector.

    The original URL sent to me looked like this: https://aaa.aaa.aa.region.aa.aa.es.io:9243/app/aa/a/

    I am still able to manually log in when I shorten it to: https://aaa.aaa.aa.region.aa.aa.es.io:9243 - to match your example.

    However, neither of these are working in the connector. I've verified that I did not paste in any extra spaces in the username and password. Both of these contain at least one @ symbol, is there any chance that could be an issue? I have a support ticket open on this as well, and I'll let them know that you've seen this connector work with that format in the Host field.

    Here is the error that I am getting: Failed to authenticate. Verify the credentials and try again. Domo is ready, but the credentials you entered are invalid. Verify your account credentials and try again.

  • mlee
    mlee ⚪️

    Another thing just occurred to me - is there more than one Elastic product? Maybe the connector is not for the same service that I have a login for.

  • TDanis
    TDanis

    domo

    💎

    @mlee There is only one ElasticSeach connector. That's good you have a support case. Engineering will likely need your credentials to debug the connector. We typically only see issues with escape characters being used in password fields. The only thing I could think of is if there is an IP restriction on that server but if you can log in and they didn't need your IP that's probably not it. https://domo-support.domo.com/s/article/360043630093?language=en_US

    If I have answered your question, please click "Yes" on my comment option.

  • mlee
    mlee ⚪️

    Thank you, I've updated my ticket to request help from the engineering team.