When using a calendar card, the calendar is not shown when only one value is in the dataset.

gdude
gdude ⚪️
edited December 2022 in Charting

The left picture shows the same card as the right picture, but in the left picture there is only 1 value but it doesn't show the calendar

Answers

  • Hi @gdude ,


    So in your calendar chart (right picture) you have that value set to count of values and not sum right? Is that what you're looking for? For Dec 14 to be a lighter color because it's only 1 value?

    John Le

    You're only one dashboard away. 

    More video solutions at: https://www.dashboarddudes.com/pantry

  • @gdude It sounds like this may be a bug in the calendar chart type. I suggest passing this along to support to be sure.

  • gdude
    gdude ⚪️

    All thanks for your reply, sorry for not responding earlier but I was tied-up in other projects.

    I passed it to DOMO as a bug and got the following answer :

    "I went back to take a look at your dashboard to look at an example, and while looking at “G1 monitor Instructions Airdata” found near the bottom. I think there is a way to display that data closer to what you’re looking for (and likely the other cards that you're having issues with).

    I'm using "G1 monitor Instructions Airdata" as an example, because it is displaying the text instead of the calendar, but the data also includes data a few months from now.

    You actually can get it to display the calendar with only the 1 day of data, but it requires you to change some Chart Properties. I apologize I didn't mention this in my first response.

    If you go to Chart Properties > General > View > Month - it will show you a month calendar.

    Then you can change the Dates from > Current Date.

    If all you do is make those 2 changes on that single card, you will see it displayed as desired. The only caveat with this solution, is that next month when there is no data the card will say "No data in filtered range". It will say this until the current month is the month with the data. This might be what you want.

    Additionally, if you want to always show the calendar, even for the months without data, you can change your date range in the top right of the card to show "All Time" rather than "This Month". This will always show the calendar card, even for the blank months.

    Also, from additional testing I've done, I've found that those 2 settings that I mentioned above (View > Month and Dates from > Current Date) should allow you to have your card to display a calendar as expected for nearly every scenario.

    To reiterate more concisely, if you want the calendar to show, go ahead and change the settings mentioned above. If you want the calendar to say "no data" on months without any data, keep your Date Range at "This Month" and if you want the calendar to show you can change the date range to "All Time" or "This Year".

    "