We use 3000 as the year for "forever" it shows in data preview but not in the final dataset

Our employee team assignments are dated with a start and end date. If it is their current assignement, the date is 1/1/3000. I discovered that when I bring the data in through workbench with a select *, it recognizes it as a date column and displays 01-01-3000 in hte data preview but when the dataset is created, it is null. 


I tried an if statement using the year function and returning 2099-1-1. This worked but now I have an extra column. Is there a way to edit the validation rules? 


  • Hi all,

    Can anybody help @WHM with their question?



  •  What version of Workbench are you using? I'm running some tests on this, but if I knew the version it would help with the testing. Thank you in advance!

  • @WHM, can you answer the follow-up question to better assist you?

  • Workbench 4


    I ended up doing a replace in a transform to replace the year with something in hte future that still looks like a year to Domo - 2099. It would be nice if the definitions of what Workbench considers an error were listsed somewhere. or even better were configurable... Sorry for the delayed response.

This discussion has been closed.