Error with size field on SQL

Dear friends,


I am uning the Jira conector to get details about Issues openend. A few days ago was necessary to execute a migration on Jira and with this action the custom fields received the sufix (migrated).


After this process a facing to use the Dataset on SQL process.


The system has return the folowing error message:


""Identifier name must be 64 characters or less: 'DOD.6. Segurança e Negócio: Foram verificados os itens abaixo? (migrated 2)'."


Someone has a idea how to deal whit this problem.


Regards Genival Junior

Best Answer

  • GrantSmith
    GrantSmith Indiana 🥷
    edited March 2021 Answer ✓

    Hi @user025461

    This is because MySQL 5.6 (version Domo is built off of) doesn't support column names longer than 64 characters. You have a few options to work around this issue.

    1) Use a Dataset view (or a magic ETL) to rename your column to something less than 64 characters and then use that dataset inside your MySQL dataflow

    2) (Better Option) Convert your dataflow to a MySQL Magic ETL 2.0 dataflow which will be much more performant and support the longer column names.

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**

Answers

  • MarkSnodgrass
    MarkSnodgrass Portland, Oregon 🥷

    Is that error referencing a column name, or the data in a particular column?

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • Genival_Junior
    Genival_Junior Brasil ⚪️

    Hi Grant,

    How does it work to convert the Dataflow to MySQL 2.0 ?

    I already solve my problem treating the field name in ETL, but this action could help me in another situations.

    Best Regards,

    Genival Junior

  • GrantSmith
    GrantSmith Indiana 🥷

    Apologies, I had MySQL on the brain but mean to state Magic ETL 2.0.

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**