Workbench - Preview Schema Data Type Error

Fatias
Fatias ⚪️
edited June 20 in Workbench

We have been trying Workbench in different computers including the main server where we will upload data to our Domo instance.

In this example, we are uploading data from a CSV file which have different data types (STRING, DATETIME, DECIMAL) and, in general, in all computers the Workbench maps the schema correctly during the preview.

On the other hand, in the main server, when we do the preview it maps everything as STRING. The problem is that when we try to change the schema from STRING to DATETIME or DECIMAL is returns an error.

We think it may be due to the way Workbench is interpreting dates and points/commas for decimals. We have tried to change the region settings of the server but the problem persists. Any suggestion how this can be changed for Workbench?


Tagged:

Best Answer

  • Fatias
    Fatias ⚪️
    Answer ✓

    We were able to solve the issue: we have changed the format settings in the Registry Editor by going to HKEY_USERS\.DEFAULT\Control Panel\International and there we have changed the values for the needed strings.

    Notice that we needed to change in HKEY_USERS to affect all the server. When we were changing the region settings in the control panel we were changing only for the user logged in


Answers

  • GrantSmith
    GrantSmith Indiana 🥷

    Domo Workbench is attempting to process everything in an American way. To get around the date issue you can utilize a Custom Date Format Transform on your data where you can specify the specific date format for Domo to interpret your data.

    https://domohelp.domo.com/hc/en-us/articles/4407013674519-Setting-a-Custom-Date-Format-on-a-Column-in-Workbench-5-1

    As for the numerical column you could utilize a Search & Replace Transform to replace the commas with decimals so Domo can interpret the data properly.


    It's not ideal but should get around your issues.

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**