Date Preset

Reply
Highlighted
Brown Belt

Date Preset

Does anyone have a problem using Date Presets as an interactive filter?  My case is that I have a slide filter, using a date field.  It works fine and the cards on the page show the filter when one is applied.  When I change the slide filter to a date selector using presets, the filter doesn't apply to all of the other cards on the page.  It works for a few but not all.  The field has not changed, just the filter style.  Any suggestions?  Thank you, Matt

Highlighted
Black Belt

I have used the preset date filter and it worked for me. I would re-check the interaction filters if you are using a story page. I have found them to be a little glitchy and not save everything every time.




**Make sure to like any users posts that helped you and accept the ones who solved your issue.**
Highlighted
Brown Belt

Thanks @MarkSnodgrass , Yes, I've used them too but I'm getting some weirdness here.  Take a look at this.  

 

Original - Slider:

slider Dateslider Date

 

Change the same filter to presets:

Date Filter as Preset with no datasets.JPGDate Filter as Preset.JPG

 

Notice that on the presets, all the datasets that it previously had been connected to have been dropped (I don't have screenshots of those, but they were there).  Then in the last picture, you see the name changes from just "Date" to "Date (by day)".

 

 

Highlighted
Brown Belt

I figured it out.  I think it is still a bug but here is what happens.

 

If you have a field from the datasource going from slider to preset works fine.  If your date is a beast mode created date (say to get the names to line up across datasets), it does not work.  It works fine on a slider, but not a preset.

Announcements
Domopalooza 2021 Call for Presenters: We want to hear how Domo is revolutionizing the way you do business!

Click here to submit your story.