Date range filter not working properly

Reply
Highlighted
Yellow Belt

Date range filter not working properly

Hi,

 

I have a query on the date range filters in cards. I have a card and filtered date range to show last 12 months by month, and then if I just select the date range ‘this year, by month’, instead of reformatting the card to show those months only(inside the analyzer when I select This year, I am able to see this year months but outside the analyzer which is after saving the card when I filter as This year by month last year months are visible but there is no data displayed for previous year), I can still see the beginning of months as blank.

There are two fields (date, department) that I have sorted. When I remove department field from the sort section the date range filter works perfectly fine.

Let me know if I am missing something.

 

Capture.JPG

 

Thanks

Highlighted
Black Belt

your use case sounds convoluted and it sounds like you have conflicting filters.

 

If i understand you,

in the CARD you're filtering for the last 12 months.

in the DASHBOARD you're filtering for the CURRENT Year.

 

The dashboard will override your filters and limit you to data from the current year, (i.e. 9 months).

Best practices says, only put filters on the card that you DON'T plan to apply at the dashboard.

 

It's unclear to me why adding or changing Department is having any impact on this... if I had to guess it's a red herring (ignore this piece of interaction) and design assuming base functionality works as previously described.

 

 

 

 


Jae Wilson
Check out my Domo Training YouTube Channel

**Say "Thanks" by clicking the heart in the post that helped you.
**Please mark the post that solves your problem by clicking on "Accept as Solution"
Highlighted
Yellow Belt

Hi @jaeW_at_Onyx ,

 

I have set the date range to Last 12 months in analyzer. When I filter to Current year, last year months are visible but with no data. In general, when we filter for Current year, only current months should be displayed.

I did not add the card to dashboard. 

Anyway, the filters are working fine now even though I haven't change anything from my end.

 

Thanks

Announcements
Domopalooza 2021 Call for Presenters: We want to hear how Domo is revolutionizing the way you do business!

Click here to submit your story.