Configure tab is missing in preview dataflow

Reply
Highlighted
Yellow Belt

Configure tab is missing in preview dataflow

Hi, I am trying to run SQL query on the dataset that has 17M rows. In dataflow that I created, I selected an input data but it only shows 500k rows. After some google foo, I figured that I have to run "Entire DataSet" in the Configure tab in the "Preview of X dataset". However, the Configure tab is missing. How do I filter an existing dataset w/ SQL and get all the rows in this case? 

 

Thank you. 

 

 

Highlighted
Yellow Belt

Re: Configure tab is missing in preview dataflow

Looks like the interface has changed This is the view I see when I create a SQL data flow and add a Dataset.

 

Screen Shot 2019-11-11 at 12.06.41 pm.png

By Default, Once you've saved the Dataflow, it will run for the entire input dataset.

 

Let me know if i understood this correctly. More screenshots, the better Smiley Happy

Highlighted
Yellow Belt

Re: Configure tab is missing in preview dataflow

That's what I would have expected as well, however, it doesn't get the entire dataset. Only 500k rows. Maybe this is the limit? And if so, what is a workaround. I need the entire dataset to be run. 

My input dataset consists of 177M rows - I want to filter it in such a way that it will only give me the filtered results. So the problem is - it doesn't see the entire dataset, hence can't filter correctly. 

 

Here is a screenshot and it says that only 500k rows loaded. I tried to run a sql query to get only October month - no records match the data. I assume it's because it simply doesn't see the entire dataset.

 

Thank you for your help!

 

Announcements
Coming Soon: Weekly Virtual User Meet-ups to answer all your questions! Stay tuned for more details to come this week.