Workbench 5 Connection String has not been initialized

Reply
Green Belt

Workbench 5 Connection String has not been initialized

Putting in the connection string when connecting to a source like OLEDB, more specifically SQL Server, has always seemed finicky but now with Workbench 5 I'm having an even more hard time. 

 

I put it in as the whole string at once, it fills in the fields on it's own such as Catalog = , Data Source = , Username =, etc. I hit apply on the window the pops up when you click in the connection (shown in blue in screenshot). This populates all those things in the OLAP Connection box, ok so everything seems fine. I click Apply to the whole thing (the one in red) and click preview. I then get an error saying [02.07.19 1:25:36 PM] The ConnectionString property has not been initialized. I go back to the connection string settings and it's all gone, like I never put it in? What am I missing?

Highlighted
White Belt

Re: Workbench 5 Connection String has not been initialized

Hi guiterhero23,

 

Would you try...

Provider=OraOLEDB.Oracle;
Data Source
=(DESCRIPTION=(CID=GTU_APP)(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=myHost)(PORT=myPort)))(CONNECT_DATA=(SID=MyOracleSID)(SERVER=DEDICATED)));
User Id
=myUsername;Password=myPassword;

Reference: https://www.connectionstrings.com/oracle-provider-for-ole-db-oraoledb/

 

to see if you can connector to Workbench 5?

 

Thank you!

Msan

Green Belt

Re: Workbench 5 Connection String has not been initialized

The one I was able to use in the previous version (and works in Workbench 5 in terms of populating the boxes, just doesn't actually save) is Provider=sqloledb;Data Source=XXXXXX;Initial Catalog=XXXXXX;User Id=XXXXXX;Password=XXXXXX

 

Not sure how Oracle differs but this one is for Microsoft SQL Server

Announcements
Win free lodging at Domopalooza! We want to hear your Domo story, enter our Dojo contest and win up to four nights lodging at Domopalooza. Click here!