workbench 5 error loading data

Reply
Highlighted
Welcome to Dojo

workbench 5 error loading data

I successfully upgraded from workbench 4 to 5, with all my scheduled jobs successfully migrated. I have encountered an error loading data into the data source for all jobs. Is this something, anyone has experienced with workbench 5?

The scheduled jobs are of a Local File Provider Transport Type and of an Excel Dataset Type

 

Please see below trace log

[02.06.19 8:33:55 AM] Determining execution parameters
[02.06.19 8:33:58 AM] Starting execution of job AR to Domo DataSet
[02.06.19 8:33:58 AM] Saving the Workbench DataSet Job to Domo.
[02.06.19 8:33:58 AM] Updating Agent Job '171' configuration on the Domo server.
[02.06.19 8:33:58 AM] Loading local file provider properties
[02.06.19 8:33:58 AM] Loading Excel file: C:\Users\E0653399\0147 Domo AR Dashboard.xlsx
[02.06.19 8:33:59 AM] Requesting Excel source file from the Local File Provider
[02.06.19 8:33:59 AM] Parsing Worksheet: Credit Limits, found 27 rows and 4 columns
[02.06.19 8:33:59 AM] Creating the 'AR' DataSet.
[02.06.19 8:33:59 AM] Retrieving DataProvider types
[02.06.19 8:33:59 AM] Creating Stream
[02.06.19 8:34:00 AM] Creating execution for Stream 1224 with UpdateMethod REPLACE
[02.06.19 8:34:00 AM] Requesting Domo DataSet.
[02.06.19 8:34:00 AM] Sending data to Domo.
[02.06.19 8:34:00 AM] Creating multi-part execution for upload ID '1'
[02.06.19 8:34:00 AM] Beginning upload of 1 data parts.
[02.06.19 8:34:00 AM] Uploading part 1 with execution 1 on Stream 1224
[02.06.19 8:34:00 AM] Domo web communication returned error status: BadRequest
Invalid CSV provided during upload. msg=There are too few columns. Expected 4. Row 1, column 4. Row: "APAC","AU01","Australia"

[02.06.19 8:34:01 AM] Server reported error: 'Response status code does not indicate success: 400 (Bad Request).' uploading data part 1. Retrying in 10 seconds.
[02.06.19 8:34:11 AM] Uploading part 1 with execution 1 on Stream 1224
[02.06.19 8:34:11 AM] Domo web communication returned error status: BadRequest
Invalid CSV provided during upload. msg=There are too few columns. Expected 4. Row 1, column 4. Row: "APAC","AU01","Australia"

 

Visitor

Re: workbench 5 error loading data

It looks like this is an issue with the CSV you're using. The error message is showing a specific row which is missing data for one of the columns, as it says:

There are too few columns. Expected 4. Row 1, column 4. Row: "APAC","AU01","Australia"

I'd recommend testing it out with a previously-used file to see if it works. 

In addition, you can utlize the options in the "configure" tab under "Advanced settings" to tell Workbench how to handle missing/problematic data or changes in columns/schema.

workbench-error-handling.PNG

 

Good luck!

Orange Belt

Re: workbench 5 error loading data

Agreed, A few more things to check. Make sure the schema matches or that you have the box to allow schema changes if it doesn't. You may also want to check for Duplicate column names and check your CSV file in a CSV validator for errors. 

Cheers

Announcements
Looking for the latest Dojo Community solutions? Click on the "NEW SOLUTIONS' widget title or go to https://dojo.domo.com/solutions Click here!